Login | Signup

World Of Warcraft Patch 5.0.4 Out Now In Europe

Author:
Carl Phillips
Category:
News
Tags:
Blizzard Entertainment, Patches, World of Warcraft, World of Warcraft: Mists of Pandaria

World Of Warcraft Patch 5.0.4 Out Now In Europe

In Prep For Mists Of Pandaria

We’re just a month away from Mists Of Pandaria’s release, and in prep for this Blizzard has released what is best described as the “prologue” patch for its MMO World of Warcraft. There are a number of changes that are coming into effect with this update, the most notable being the revisions to the Talent trees, and the addition of account-wide pets and mounts. To help explain everything, Blizzard have released a video detailing everything about the patch which you can find after the jump.

The patch itself will optimise your installation “to improve game performance and reduce the size of the install,” however the process can last somewhere between 15 – 60 minutes “under normal conditions.” We advise you take this into consideration if you are planning on trying out the changes today. That said, an update from the European Customer Service Twitter account this morning account suggests that the game will not be playable until 14:00 today, so there's plenty of time to get everything ready if you're not working today.

Mists of Pandaria, the fourth expansion for World of Warcraft, releases on September 25th.

Add a comment3 comments
Vynd  Aug. 29, 2012 at 13:22

It's not going well so far. Launch WoW on both computers and both of course say they need to optimise (as stated in the article) and an hour later both are sitting at 0% complete.

Looking into the system processes, the Blizzard downloader is still running, using CPU and very small amounts of network in and out but no progress.

From a quick scout on the forums, a lot of people are having the same problem. I can only assume that the servers are completely overloaded. There goes my plan to re-spec all the talents on my characters today!

So a word of warning to all WoW players, if you're meant to be raiding tonight, it might be cancelled!

Vynd  Aug. 29, 2012 at 14:20

At last, found a fix. Here is the blue post from the Blizzard forums that appears to have jump started the optimisation:

Installation stuck at 0%

The re-optimisation progress bar will incorrectly show 0% until the optimisation is complete. Please allow at least an hour for this to finish. If this persists after this time, please try deleting the Battle.net folders:
[WINDOWS XP]
C:\Documents and Settings\All Users\Application Data\Battle.net
[WINDOWS VISTA/7]
C:\ProgramData\Battle.net
[MAC OS X]
/Users/Shared/Blizzard/Battle.net

**Note** you will need to enable hidden files and folders on your system in order to see the Program Data and Application Data folders on Windows systems.

Please also make sure the game executables aren't set to be Read Only. To do this, right click on the following files and choose Properties:
Launcher.exe
Wow.exe
Blizzard Updater.exe
Repair.exe
Wow-64.exe (if present)


Then on the Properties window, please ensure that Read Only is not ticked.

Additionally, if on OS X, the older pre-5.0.4 Launcher may be launched concurrently with the newer one. Please switch to this older launcher and close it, and let the re-optimisation complete.


Hope this is useful to anyone else staring at 0%.

JonLester  Aug. 29, 2012 at 14:31

Many thanks Vynd, I'm sure plenty of readers will find this useful. 8)

Trackbacks

Leave a Trackback from your own site

Email Address:

You don't need an account to comment. Just enter your email address. We'll keep it private.